Tableur

Exercice de découverte du tableur, pour la gestion de stock Exercice basique, ultra-débutant, de découverte du tableur

Exercice LibreOffice Calc, pour le suivi de stock, un exercice super-super simple, à la portée de toutes et tous, pour comprendre le fonctionnement du tableur.

Poser les besoins :

Nous devons gérer un atelier de matériels d’une collectivité territoriale. Nous y trouvons des chaises, des tables, des bancs, prêtés à la semaine.
Il nous faut tenir les enregistrements des entrées sorties :
- enregistrer ce qui sort, pour qui, à quelle date,
- noter le nombre d’unités,
- enregistrer les retours, avec la date, et les observations éventuelles.

Résumer les informations nécessaires :
- le numéro de la semaine,
- la date exacte,
- la structure qui emprunte,
- le stock initial du matériel,
- le nombre d’unités sorties,
- la date de retour,
- le nombre d’unités entrées,
- l’état du stock à tout moment, le nombre d’unités disponibles,
- l’observation si nécessaire.

Organiser les informations :
- entrer un mot, une expression courte, par en-tête de colonne ; semaines en A1, dates en B1, structures en C1, unités en D1, chaises disponibles en E1, état du stock en G1, observations en H1.
- entrer le stock initial pour le matériel décompté, sur la première ligne, en D2, entrez le nombre 500, en C2 entrez "stock de chaies", en B2 entrez la date initiale.
- entrer quelques données pour valider les premiers tests.

Renommer les feuilles de votre classeur :
Pour renommer les feuilles, faites un double-clic sur l’onglet, tout en bas, de la feuille concernée, changez son appellation et validez.
- renommer la feuille1 pour le décompte des chaises,
- renommer la feuille2 pour le décompte des tables, etc...

Entrer les numéros de semaines :
- entrer les premières semaines, 1, 2,...
- l’étendue des entrées sera entre 1 et 52 :-)
- entrer un même chiffre sur plusieurs cellules en incrémentant avec la touche CTRL enfoncée (plus rapide et pratique que de copier et coller).

Entrer les dates exactes :

pour entrer une date, il faut :
- séparer les chiffres des jours et les chiffres des mois, par un "/" slash,
- séparer les chiffre des mois et les chiffres des années, par un "/" slash,
- entrer 01/01 suffit, le tableur connaît l’année en cours,
- 01/01/14 indique la date du 1er janvier 2014,
- 01/01 aussi.
- faire attention de ne pas insérer d’espace vide, avant ou après les chiffres,
- s’assurer que l’année est bien entrée en quatre chiffres dans la barre des formules.

Créer votre document tableur :
- enregistrer votre document, ne faites pas confiance dans votre ordinateur !
- vous devriez obtenir un début de fichier comme celui ci-dessous.

fichier gestion de stock 1 :

Entrer les données de tests :
- dites-vous qu’une sortie de chaises se note en négatif, en plaçant un moins devant le nombre de chaises,
- dites-vous qu’une entrée de chaises se note en positif, sans placer de signe devant.

fichier gestion de stock 2 :

Calculer le nombre de chaises disponibles :
- entrez en E2, le stock initial, =D2,
- entrez en E3, la formule de calcul =E2+D3,
- incrémentez la formule jusqu’à la ligne 23.

fichier gestion de stock 3 :

Calculer l’état du stock :
- l’état du stock à la date initiale est indiqué dans la cellule E2,
- l’état du stock se calcul à partir de la première sortie, sur la ligne 2, lorsqu’il revient sur le nombre de 500 chaises, alors il est au complet.
- l’idée est d’utiliser une formule conditionnelle (pour complexifier un peu le tableau :-)). Entrez en G2 la formule suivante [1] : =SI(E3=500 ;"ok, stock initial" ;E3-$E$2).
- incrémentez [2] cette formule jusqu’à la ligne 23.

Utiliser la formule =SI() :
la formule ci-dessus se décompose de la manière suivante :
- =SI(test ;valeur si vrai ; valeur si faux)
- le test est E3=500
- la valeur si vrai est "ok, stock initial" (tous les mots doivent être entre guillemets),
- la valeur si faux est E3-$E$2, E3 étant le nombre de chaises disponibles, E2 étant le stock initial (les dollars sont utilisés pour fixer la cellule).

fichier gestion de stock 4 :


En précisant qu’une table de données de stock se gère plus efficacement avec le pilote de données, mais c’est une autre histoire...

Notes

[1vous pouvez la copier et la coller

[2tirez votre cellule depuis le petit carré gras qui se trouve à son angle inférieur droit

Documents joints